Configuration Guide 7. IPSec Tunneling
Version 7.2 35 Security Setup
7.1.2 Configuring IPSec with GRE
This example includes IPSec with GRE where two devices are connected back to back via
the Gigabit Ethernet 0/0 interface. Only GRE traffic that is being "caught" by the access list
permit gre any any, between the Gigabit Ethernet interfaces is encrypted.
Figure 7-3: GRE over IPSec
The following shows the MSBR1 configuration:
conf d
int gigabitethernet 0/0
ip address 180.1.1.1 255.255.255.0
no firewall enable
exit
int vla 1
ip address 192.168.11.1 255.255.255.0
exit
int vla 2
ip address 192.168.12.1 255.255.255.0
no shutdown
exit
int vla 3
ip address 192.168.13.1 255.255.255.0
no shutdown
exit
interface gre 1
ip address 1.1.1.1 255.255.255.0
tunnel destination 180.1.1.2
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 180.1.1.2 gigabitethernet 0/0