Issue 2.0
SV9100 Networking Manual 5-31
Configuration Example Explanation:
1. Defines a Class Map called VoIPClass.
2. Matches any packets that have the ToS field set to IP
Precedence 5 / DSCP 40 and assigns them to VoIPClass.
3. Defines a Policy Map called VoIPPolicy.
4. Creates a Class called VoIPClass and assigns this to the
VoIPPolicy.
5. Allocates 50Kbps of bandwidth to the VoIPClass.
6 & 7.Determines that any data that does not match VoIPClass
should be processed using the “fair-queue” method (i.e., No
Prioritization).
8. Determines the amount of bandwidth available on the Serial
interface – essential for the QoS calculations.
9. Applies the VoIP Policy to any packets that exit the serial
interface. This means that data being received (input) does
not use this policy.
Table 5-6 Cisco Router Configuration Example
Current Configuration : 2023 bytes
version 12.3
hostname Cisco2621
|
class-map match-any VoIPClass (1)
match ip dscp cs5 (2)
policy-map VoIPPolicy (3)
class VoIPClass (4)
priority 50 (5)
class class-default (6)
fair-queue (7)
|
interface FastEthernet0/0
description Connects to Dallas LAN
ip address 192.168.1.1 255.255.255.0
|
interface Serial0/0
description Connects to Fort Worth via Kilostream
bandwidth 256 (8)
ip address 10.0.0.1 255.255.0.0
service-policy output VoIPPolicy (9)
encapsulation ppp
|
ip route 0.0.0.0 0.0.0.0 10.0.0.2